[GEM-dev] Offscreen naming poll!
IOhannes m zmoelnig
zmoelnig at iem.at
Wed Nov 30 18:22:46 CET 2005
B. Bogart wrote:
> gembuffer ?
> gembuf? (gemwin)
> james tittle wrote:
>> name it, and where it should go in the folder hierarchy? Currently
>> it's named [gemframebuffer], but really I think [gemoffscreen] would be
as you state correctly, the name [gembuffer] would be coherent with the
name [gemwindow], so the functionality should be coherent too. (imo, the
same goes for [gemframebuffer] and [gemoffscreen].)
i foresee nameclashes with the multiple_windows (whenever they will come...)
>> ...also, on my harddrive I put it in src/controls (it would be inserted
>> into a gemchain after [gemhead]), but I guess it could also go in
>> src/manips, or even src/Nongeos?
could it be an option to make an alternative(!) [gemhead] out of this
so people could decide whether an entire gemchain is onscreen
([gemhead]) or offscreen ([???]).
if so, i would vote for something really clumsy like [gemhead_os]
("clumsy" since i cannot think of a better name, not because the object
_should_ be named clumsy of course)
More information about the GEM-dev