[PD-dev] list math

Mathieu Bouchard matju at artengine.ca
Tue Feb 14 13:49:46 CET 2006

On Mon, 13 Feb 2006, Hans-Christoph Steiner wrote:

> [mapping/clip] object would just be a shortcut, which could also create
> confusion.  If someone imports "math/list" before "mapping", then [clip]
> would loose its defaults.  So I think that it would probably be a better
> idea to just use [math/list/clip] in the context of mapping.

Anyone cares about higher-order functions? use a class name as the $1.

I don't want to have 666 more classes just because someone thinks that 
higher-order functions can be avoided.

I don't think there ought to be more than one [map] class.

And btw, no-one calls that a "mapping" in the real world.

What about generic [zip] [fold] [scan] now?

 _ _ __ ___ _____ ________ _____________ _____________________ ...
| Mathieu Bouchard - tél:+1.514.383.3801 - http://artengine.ca/matju
| Freelance Digital Arts Engineer, Montréal QC Canada

More information about the Pd-dev mailing list