PD->VST? (was Re: [PD] newbie: no MIDI in...)

Christian Guirreri cguirrer at runet.edu
Mon Sep 24 16:35:25 CEST 2001

Nevermind - tried after a fresh boot and everything works now (pd 
-midiindev 1 -midioutdev 1 -soundoutdev 4).  It might be related to loading 
Cubase and other ASIO software first, and then pd (as one person mentioned 
having trouble with Reaktor installed).

The sound card is an Echo Mia - wonderful card.  It has eight "virtual 
outputs," (only stereo balanaced in and out) a super quiet 24/96 digital 
mixer, SPDIF in/out, simultaneous ASIO, GSIF, and DX support.  Highly 
recommended under $200 card, though no Linux drivers I guess.

Everything runs great now - thanks everyone for your replies!  I can't wait 
to dig in...off to pure-data.org!

By the way...did anyone ever get that pd VST plugin to work?  I didn't 
understand how to setup pd to send and receive to Cubase.

Thanks again,

At 04:16 PM 9/24/01 +0200, you wrote:
>Hi again,
>I have no idea what a mia-soundcard is (that's why I'm asking)
>I am not on win98 anymore, so I cannot really help you:
>just some suggestions: inactivate the "use preferred audio device only" in 
>the audio-preference settings of the OS.
>If this doesn't work, make your MIA the preferred devices and drop the 
>-soundin/outdev-parameters when starting PD.
>Also try to define a buffersize with -audiobuf 200 or bigger. (Try -nodac 
>or -noadc to see if you can use audio in one direction)
>That's what I can suggest. Good luck.
>At 09:31 24.09.2001 -0400, you wrote:
>>Heya Michael,
>>See previous post - I'm on Win98se with an SBLive and Mia.  Intel 
>>BX-based system.
>>         Chris
>>At 02:58 PM 9/24/01 +0200, you wrote:
>>>what soundcard /OS do you have?
>>>At 08:16 24.09.2001 -0400, you wrote:
>>>>At 11:12 PM 9/22/01 +0200, you wrote:
>>>> >To solve your midi-problem,start pd with -midiindev 1 -midioutdev 1
>>>>That did it for getting MIDI...
>>>>However, now I get "audio I/O stuck... closing audio," and of course, I can
>>>>now use MIDI, but not audio, so it seems like one or the other...
>>>>I run Cubase, Reason, Reaktor, Acid...etc on a daily basis...all MIDI and
>>>>audio work fine.
>>>>Here's my listdev:
>>>>audio input device #1: SB Live! Wave In [B800]
>>>>audio input device #2: Game Compatible Device
>>>>audio input device #3: Voice Modem Wave #00 Line
>>>>audio input device #4: Mia 1/2 Analog Record
>>>>audio input device #5: Mia S/PDIF Record
>>>>audio input device #6: Virtual Cable 1 In
>>>>audio output device #1: SB Live! Wave Out [B800]
>>>>audio output device #2: Game Compatible Device
>>>>audio output device #3: Voice Modem Wave #00 Line
>>>>audio output device #4: Mia 1/2 Virtual Out
>>>>audio output device #5: Mia 3/4 Virtual Out
>>>>audio output device #6: Mia 5/6 Virtual Out
>>>>audio output device #7: Mia 7/8 Virtual Out
>>>>audio output device #8: Virtual Cable 1 Out
>>>>Current bat = pd -midiindev 1 -midioutdev 1 -soundoutdev 4
>>>>...though I tried any of the -soundoutdev's and I get the same thing every
>>>>Thanks everyone!
>>>>          Chris
>>>Michael Iber
>Michael Iber

More information about the Pd-list mailing list