[PD] jack trouble

david casal D.Casal at uea.ac.uk
Tue Oct 22 11:11:08 CEST 2002

Hi all,

Trying to to PD-->Jack. Ran into trouble:

I'm running Debian 2.4.18 on a powerbook (pismo G3). Got the CVS pd
version of devel_0_35 and compiled with './configure --enable-jack

Checked out Jack (CVS), tinkered with configure.in until
autogen worked.

tried to start jack with 'jackd -d alsa -d screamer', and it seemed fine:

loading driver ..
creating alsa driver ... screamer|1024|2|48000|swmon
starting engine

I've got a .asoundrc with:

pcm.screamer {
type hw
card 0

(aplay -l says: card 0: card0 [PowerMac Screamer], device 0: PMac

then tried to start PD with:

pd -jack -verbose

PD's output:

Pd version 0.35
(MIDI stuff)
using jack interface
cannot read event connect result from server (No such device)
cannot connect to server for event stream (No such device)
(last 2 lines repeated 5 times)
jack server not running?

Jack's output:

**** alsa_pcm: xrun of at least 4.253 msecs

unknown client ID in ACK connection request
cannot complete client ACK connection process
(last 2 lines repeated 5 times)


Thing is, I had quite a bit of trouble compiling ALSA for this powerbook,
and I fear maybe the thing's gone mad...but I'm able to 'modprobe modprobe
snd-powermac Any clues, anybody?

SOrry about long message.


> >
> Please, please, if you try this, be aware that it is unofficial.
> Then you have to go to the jackit.sf.net and install jack and configure pd
> with ./configure --enable-jack
> Greetings,
> Guenter

david casal                   --0+
d.casal at uea.ac.uk             --9+
www.ariada.uea.ac.uk/~dcasal  --)+

More information about the Pd-list mailing list