[PD] pix_video not working in Linux

Mirko Petrovich prab at terra.cl
Tue Nov 18 07:33:49 CET 2003

Hi all

I downloaded GEM from cvs (2003-11-15) and pix_video doesn't work for my 
saa7134 (V4L2) capture-card. IIRC it worked well in some 0.87 cvs 
snapshots, and after that (0.87 release) it never worked again for more 
than 10 seconds. When using pix_video I get a lot of *GEM: pix_video: do 
video for this OS* in the console and messages doesn't work :

error: pix_video: no method for 'channel'
error: pix_video: no method for 'mode'
error: pix_video: no method for 'norm'

When using pix_videoLinux with pix_rgba (because I get *error: Gem: pix 
object cannot handle RGB image*)  I get the following:

cap: name LifeView FlyVIDEO2000 type 47 channels 4 maxw 720 maxh 480 
minw 48 minh 32

picture: brightness 32896 depth 17332 palette 4

vcap.channels 4
channel 0 name Television type 1 flags 1
channel 1 name Composite1 type 2 flags 0
channel 2 name Composite2 type 2 flags 0
channel 3 name S-Video type 2 flags 0
buffer size 3981312, frames 3, offset 0 1327104

frame 0 0, format 4, width 128, height 64

GEM: pix_video: Opened video connection F
vmmap 832E0CC

but no image , only a white rectangle.
I tried sending the following messages : channel 2, norm NTSC, mode NTSC 
2 , driver 0 , device 0 also I tried pix_videoNEW but still no image. My 
capture card is working well with pdp, so in the meantime I'm using 
pdp_v4l -> pdp2gem -> GEM. but pdp2gem eats all my cpu.
I hope someone knows what is happening here.
Thanks for your time and excuse my confuse mail.

PD. the new Pixes objects are awesome !!!

Mirko Petrovich


More information about the Pd-list mailing list