[PD] PD + Gentoo

derek holzer derek at x-i.net
Sun Nov 30 17:18:19 CET 2003

Hi Frank,

Frank Barknecht wrote:

> In my opinion: As all distributions just use more or less the same
> ALSA and kernel, switching distributions will not make problems inside
> these go away.

Respectfully, I wish this was true.

But my experience showed this:

RedHat was useless for getting my PCMCIA HDSP working. I am sure that it 
is something with my hardware and the PCMCIA bridge [or something like 
that] that their patches or configurations do not like.

Planet CCRMA does NOT use Red Hat patched kernel, but their own patches 
on a vanilla kernel. I still could not get the PCMCIA stuff sorted out 
with this kernel. This led me to beleive it was something in the way Red 
Hat configured things, but I am not SUCH a guru that I could figure it 
out. [I guess I could recompile the Planet kernel to test this, but all 
the stuff is already there in terms of PCMCIA support, so I don't know 
what else to tweak.]

I was running Guenter's Unoffical DeMuDi packages successfully for a 
while, until an apt-get upgrade on regular Debian broke them. I would 
try the offical DeMuDi now, as it seems to have stabilized out, but all 
the software in normal Debian is just so damned old ;-)

Running Gentoo worked to get the HDSP running with Jack and a few other 
apps, which shows me that the PCMCIA bridge problem can be solved. 
However, the ALSA packages in Gentoo ARE weird, and other things that 
worked under Guenter's packages, and also under Planet for my PCI HDSP 
interface [like XMMS, Pd -alsa, etc] fail because of this 
interleaved/non-interleaved thing. It might just have something to do 
with the way they package it, compile options, etc, that Gentoo's USE 
flags just can't account for.

> Missing alsaconf is bad, although hdspX or envy24control et all are
> missing in Debian as well. That probably is because these are not part
> of the three essential ALSA packages alsa-lib, alsa-utils and
> alsa-modules and are only needed in special cases (you don't need
> envy24control, I don't need hdsploader)

HdspX are part of ALSA-tools, for several versions now, and they should 
come with the Gentoo ebuild. If I took an up-to-date alsa-tools .deb, I 
would expect to see them there as well.

Ahhhhhhhhhh, another chapter in the long saga known as "Linux HDSP" ;-)

Of course, I will let the world know one way or the other how it pans 


More information about the Pd-list mailing list