[PD] Can't open files. no files matched glob pattern "*"

Ian Smith-Heisters heisters at 0x09.com
Fri Feb 11 16:47:53 CET 2005

Hi all,

I've ended up with a rather wierd error running Pd 0.38-2 from Miller's
site. Compiled it last night, it worked fine, in the morning it started
printing this to the terminal when I try to open a file:

no files matched glob pattern "*"

The window it then opens is blank, does not respond to mouse events, and
has a title like "X83CDD80". If I do a file-> new *before* I open
anything else it works fine, until I try to open something, then even
file->new has the same result.

Running it compiled with --enable-debug under gdb revealed only this

invalid command name ".x83ce1e0.m.windows"

when I closed one of the windows. The compilation was with --enable-alsa
and --enable-jack

I'm on debian SID with tcl/tk 8.4.9-1. I compiled exactly the same
release on another debian SID system with same tcl/tk version last night
and that one works fine.

So far all I've figured might help is recompiling and rebooting. Neither 
did. I tried it without my .pdrc to see if it was an external, and it 
had no change.

Any suggestions?


Ian Smith-Heisters

More information about the Pd-list mailing list