[PD] could not open alsa sequencer

Ben Dembroski info at arthacking.org
Sat Apr 2 16:57:51 CEST 2005


I'm very much a PD newbie and more or less a Linux newbie, and am having trouble getting a new PD installation to play nice with ALSA (or is it the other way around?)

I am running Debian sid (kernel 2.6.10-K7), with PD installed via apt-get (0.38.4+amidi-1)

When I try to start PD, it returns the following in the terminal:

~$ pd -alsa
ALSA lib seq-hw.c:446:(snd_seq_hw_open) open  /dev/snd/seq failed: No such file or directory
Pd: system called timed out

Other sound apps seem to be working OK, audacity and xmms are making sounds with no problem, via ALSA (i'm assuming)

I am using a Creative SB audigy card. Just for kicks, I tried using my MOBO's built in sound card, and got the same result.

I've done the usual google searches, and looked on the list archives, and found nothing.

Does this sound like a PD problem, or is it more likely that the configuration of ALSA is the culprit?

For what it's worth, I had an Unbuntu Warty install on the same box about a month ago with no problems. I do believe the version of PD was .37 on that install. Unbuntu was nice, but I like the choice of packages that sid is giving me, so I would like to try to get this setup going.

Any suggestions?

Many thanks,

Ben Dembroski

More information about the Pd-list mailing list