[PD] GEM: build error FTFont.h

Paris Treantafeles paris at parisgraphics.com
Fri Apr 29 05:34:22 CEST 2005

hi jamie and list,

i'm still getting the error and would appreciate any help - i'll admit 
this is the first time i've tried to compile anything so i'm probably 
doing something stupid...

1. i got GEM and GEMLibs from CVS. i found GEM_darwin.pbproj and loaded 
it with project builder.

2. there were a few errors on building that were solved by removing 
some files outlined in a post in the archives.

3. got the error below.

4. installed freetype2 using fink

5. downloaded FTGL which also had a project builder file. i used that 
and it built a libftgl.a file.
i wasn't really sure where to add that to the GEM_darwin project, so i 
tried a few places, e.g. GemLibs, frameworks, but still got the error 

so assuming that i really have ftgl and freetype2 on my machine, how do 
i tell project builder (xcode, i guess?) about them?

or...  is there a way to build Gem without font support? i don't really 
need that anyway.


On Thursday, April 28, 2005, at 10:30  AM, james tittle wrote:

> On Apr 28, 2005, at 10:24 AM, paris at parisgraphics.com wrote:
>> hello,
>> i'm trying to build gem from cvs on mac os x.
>> i've gone through the archives and found answers that solved all but 
>> one
>> problem. can anyone point me in the right direction to fix these 
>> errors?
>> Thanks,
>> paris
>> In file included from src/Base/TextBase.cpp:17:
>> src/Base/TextBase.h:23:20: FTFont.h: No such file or directory
> ...do you have freetype2 and FTGL installed, and if so, does the 
> makefile know where to look for the headers and libs?
> jamie
> _______________________________________________
> PD-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> 
> http://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list