[PD] fluid~ and flext~ compilation on OSX

David Plans Casal david at khandaan.org
Sat Jun 25 14:24:32 CEST 2005

Hi Frank! (sorry sent reply to you directly first)

On 24 Jun 2005, at 16:45, Frank Barknecht wrote:

>> make: *** No rule to make target `pd-darwin/fluid~.pd_darwin', needed
>> by `all'.  Stop.
> It might be, that the directory "pd-darwin" is missing. I'm not sure,
> if flext-build.sh creates this if it's not there. It is not in CVS, so
> maybe "mkdir pd-darwin" could help here, then again try:

The problem has compounded a bit:

I recompiled fluidsynth without readline, and tried fluid~ compilation 
again. Unfortunately, I see:

waldorf:~/Development/music/pd/externals/footils/fluid dc$ g++ -bundle 
-bundle_loader /usr/local/bin/pd -flat_namespace pd-darwin/fluid.o -lm 
-L/usr/local/lib -lfluidsynth /usr/local/lib/pd/flext/flext.a  -o 
ld: Undefined symbols:
flext_base::GetClassArr(_class*, int)

Looks like it can't cope with the flext library I compiled...I go into 
flext cvs, but when I try 'sudo bash build.sh pd gcc', I get:

waldorf:~/Development/music/pd/externals/grill/flext dc$ sudo bash 
build.sh pd gccPassword:make -f ./buildsys/gnumake-sub.mak PLATFORM=mac 
RTSYS=pd COMPILER=gcc BUILDPATH=./buildsys/ PKGINFO=package.txt 
BUILDCLASS=flext USRCONFIG=config.txt USRMAKE=build/gnumake-mac-gcc.inc 
TARGETMODE=release TARGETTYPE=single _build_
buildsys/mac/gnumake-gcc-flext.inc:27: warning: overriding commands for 
target `pd-darwin/release-single'
buildsys/mac/gnumake-gcc-flext.inc:24: warning: ignoring old commands 
for target `pd-darwin/release-single'
g++ -c -faltivec -ffast-math -DNDEBUG -O3 -mcpu=G4 -DFLEXT_USE_SIMD 
-DFLEXT_EXPORTS -DFLEXT_SYS=2 -include pd-darwin/release-single/flext.h 
-I/Applications/Pd-0.38-3.app/Contents/Resources/src source/flbase.cpp 
-o pd-darwin/release-single/flbase.opp
source/flbase.cpp:28:22: g_canvas.h: No such file or directory

Since I can't figure out why that's the case, I download 
flext-0.4.7-pd-osx.tgzm I edit config-pd-darwin.txt to give it the full 
path to pd sources and tell it to build flext into 
INSTDIR=/usr/local/lib/pd/flext, then I run sh build-pd-darwin.sh, and 
while it looks like it gets compiled, at install, the following 

mv /usr/local/lib/pd/flext/lib*.dylib /usr/local/lib
ranlib /usr/local/lib/pd/flext/*.a  # have to rerun ranlib at install 
dir ?!
ranlib: file: /usr/local/lib/pd/flext/flext.a(flthr.o) has no symbols
ranlib: file: /usr/local/lib/pd/flext/libflext.a(flthr.o) has no symbols

I tried:

waldorf:/usr/local/lib/pd/flext dc$ sudo ranlib flext.a
ranlib: file: flext.a(flthr.o) has no symbols

Same message.

Am I correct in assuming that, at this point, fluid~ will not compile 
because the flext libraries that I've compiled are not healthy?

Any ideas?

Thanks for you help,


More information about the Pd-list mailing list