[PD] delay on startup and startup flags under OSX

Samuel Burt brialey at juno.com
Fri Sep 2 17:59:01 CEST 2005

Yep, I've been getting similar delays in 10.3.9 with a modified version 
of Hans installer.

I just launched Pd from the command line inside the .app/Contents/MacOS/ 
folder.  I'm not sure if I need to pass it some other flags, but I got a 
long stream of unending MIDI commentary that continues on through the 
normal operation of Pd:

goomba:/Applications/Pd-0.38.4-extended-RC2-SB.app/Contents/MacOS sburt$ 
DebugAssert: Third Party Client: err== noErr [-536870163]  [line 283, 
file Shared/USBDevice.cpp]
device @ 0x1A100000 - can't get descriptor
2005-09-02 11:47:37.537 MIDIServer[591] receiving message (running:1 
messageID:1 size:35)
2005-09-02 11:47:37.538 MIDIServer[591] MIDI in length:1 data:FE000000 

and it just keeps repeating the last two messages over and over.  I even 
tried switching the MIDI in to a different device.  Are these statement 
just part of the normal running of Pd?

Also, the -nogui flag doesn't seem to work for me, either.

I haven't noticed any problems with my Pd installation running poorly 
with audio or MIDI.  I'm not too concerned about it, but I hope sharing 
my information helps debug the problem.

Samuel Burt

Message: 6 Date: Fri, 02 Sep 2005 14:12:28 +0200 From: altern 
<altern2 at gmail.com> Subject: [PD] delay on startup and startup flags 
under OSX To: pd-list <pd-list at iem.at> Message-ID: 
<431841AC.8050801 at gmail.com> Content-Type: text/plain; 
charset=ISO-8859-1; format=flowed hi *first question: few months ago I 
was asking about a strange delay that i was getting when launching PD on 
OSX. When i run Pd it opens and it takes few secs to react or to open 
the clicked file. I wrote a small script to lauch pd and I realised that 
on the terminal of the laucn script i get this mesage exactly when Pd 
comes 'back to life' CoreMIDI: timeout waiting for MIDIServer to start 
So i guess it is waiting for some MIDI device on the system to start or 
respond. anyone knows how to fix this? i dont use midi at all *Second 
question: in the same script i am passing PD some startup flags such as 
-nogui but this doesnt have any effect. Does this work under OSX or am i 
doing something wrong. thanks!
-- altern

More information about the Pd-list mailing list