[PD] newWave + video

IOhannes m zmoelnig zmoelnig at iem.at
Tue Sep 27 09:30:29 CEST 2005

Peggy Sylopp wrote:
>  >the 3rd inlet of [newWave] is the "height" inlet.
>  >alternatively (but why would you want to do that?) you could use
>  >[scaleXYZ 1 1 0.1] ;-)
> When I use scale, the wave doesn't move any more.

this seems like you are scaling by "0" (which flattens the surface)
(btw, there is a difference between [scale] and [scaleXYZ])

> The height inlet I tried before, with value 1 the spike is still very 
> high, it seems it doesn't have enough influence. It seems floats aren't 
> accepted.

the default height value is "1", so using "1" should not make much 
difference. on my system floats work fine, but since you have problems 
with both [scaleXYZ] and floating-point height values, please check 
whether floats work at all.

> Does the third value if 'position' have an influence, sometimes it seems 
> like?

yes it does (however, using "height" is something different than 
modifying the z-value of "position"; the former just scales the z-values 
of all surface points)

>  > Sometimes the texturing with a video doesn't work, and pd crashs.
> It seems to depend on the codec I use, for example cinepak doesn't work, 
> but its installed on the system. In all video and 3D programms I know 
> (After Effects, Combustion, Premiere, 3D Studio Max, Cinema 4D, 
> visualJockey) the installed codecs are working. What codecs do work, 
> what does it depend on?

so you are using w32 ? good to know...
the video-decoding API Gem is using on w32(!) is rather old and thus 
does not support all the "newest" codecs. however, you can use AVISynth 
or some other frameserver (i have only tried AVISynth) to do the actual 

>  > I tried i! t with Pd version 0.38.0, but the newWave-patch didn't work.
>  >how does it not work ?
> It simply doesn't show waves or they don't move, only when starting the 
> patch a big resonance elongation, which explodes the surface.

that is very weird, because i don't think there is anything that would 
explain the different behaviour on various pd-versions (the only thing 
that comes to my mind is, that you are probably loading another version 
of Gem when using pd-0.37)


More information about the Pd-list mailing list