[PD] pd installer for macosx not recognizing preferences

august august at develop.ment.org
Wed Mar 7 19:57:11 CET 2007

hey thanks for the replies.

> >> the instructions say: [snip]
> >>
> >> I do exactly that and while I can get PD to run, it will not load
> >> any of
> >> the libraries.
> >
> > I'm not sure i understand. What do you mean by "not load"? What
> > libraries/objects would you want to use, but can't?

well, all of them.   Gem and zexy to start with.

but I found the problem.   What happened was I put the pd.app under
applications, started it and then when I found out I didn't have the
libs I wanted, I tried to edit them in the Preferences part of the PD
GUI with "-lib Gem -lib zexy".   But, that didn't work either, probably
because I didn't set the path.   So, I read the website and followed the
instructions there about adding the org.puredata.* to
~/Library/Preferences.  But, after doing that, it didn't work either.
So, I tried to hunt down any .pdrc files that might conflict...but alas
there were none to be found under /etc or my ~/ dir where they would
normally be stored (under linux).   So, eventually I figgered that the
.app bundle was somehow storing the Preferences that I tried to set from
the GUI and I just deleted it and put the orignal from the .dmg there
instead.  Now it works.

Maybe there should be some notification or convention on which
preference files take precedence....the GUI prefs, the .pdrc, or the

I think it might make sense to just keep the prefs in only ONE global
location and ONE user-defined location which can override that.


> I had something similar the other day, when i checked out "pdmtl", an  
> abstraction collection from Montreal.
> sometimes "gem" was loaded sometimes not, the "genhead" object was  
> dotted, but if i created a new one it worked.
> And the "startup" and "path" windows are a ****sorry*** mess.
> I explain why:  If you want to add a new path, usually all the lines  
> are occupied and not all of them (around 30) are displayes so what i  
> do is :copy a line, usually change the last path-entry, and i  
> separate the two entries with a ":".
> There is the property List editor, but its somehow very uncomfortable  
> to edit entried there....
> Is sthg wrong with that ? My impression is: sometimes it works,  
> sometimes it doesnt...
> i think the "autogenerated" Preferences do not work a 100%, would it  
> be possible to have a similar script locally, that checks all the  
> folders. What was always strange to me: If you tell PD to search in a  
> path, would it not be the easiest to just check all the subfolders ???

More information about the Pd-list mailing list