[PD] ANN: munger1~ port (from the Percolate library)

Ivica Ico Bukvic ico.bukvic at gmail.com
Wed Mar 14 02:11:37 CET 2007

> Nope - still same error.  Thanks for the try though!  I think Thomas
> should be pondering this one soon.
> Kevin

Just checked it on my OSX machine and what I've done is as follows:

1) installed stk (regularly)
2) installed flext with STK enabled in the config.txt file inside the flext
folder, so that it points in the right direction
3) my libs are stored in /usr/local/lib (including libstk.a)
4) compiled munger~ with -lstk and it worked fine

Specific line shown during compile time has -lstk -lflext-max_t at the end
of the g++ call. The same call also has -L/usr/local/lib (not sure where
that one comes from, though--could be flext stuff).

FWIW, I also got an e-mail from Thomas Grill (author of flext) suggesting
that some changes have been made as far as OSX and Linux build of flext is
concerned which now allows for better integration with Stk and SndObj. I am
not sure what are the details surrounding this announcement, but this may
help resolve your problem.

Best wishes,


More information about the Pd-list mailing list