[PD] New version of plugin~

Jacob Lee artdent at gmail.com
Thu Sep 18 08:55:20 CEST 2008

On Tue, Sep 16, 2008 at 3:23 AM, IOhannes m zmoelnig <zmoelnig at iem.at> wrote:
> Jacob Lee wrote:
>> As hinted at in an earlier email (thanks for the help!), I have a new
>> version of plugin~. It supports two new messages:
>> bind foo - listens for messages sent to foo-gain, foo-drive, etc. You
>> can bind sliders, sssad objects, etc. to the same names and have
>> everything just work.
>> bindscaled foo - the same, but translates messages from the 0-127
> as 0-127 is really only because of MIDI, i would suggest using "bindmidi" or
> "bindmidiscaled" (of "bind7bitbecauseofmidiandlongnamessuck")
> in general i think we should use 0..1 for normalized ranges as much as
> possible (and as is used in the "mapping" library)

Hmm. Besides midi, the advantage of 0-127 is that it's the default
range for sliders. Of course, it's not hard to add [/ 127] and a send
below the message, but at that point you might as well replace the
division with a proper range conversion and add a [control foo $1(.
Accepting the range 0-127 means requiring nothing more than named

The question might be, which is more common:
- bare graphical objects + midi inputs
- more complicated numeric manipulations, perhaps involving the mapping library.

In my case, it's the former. Does anyone else want to weigh in?

Another possibility is to accept messages like "bindscaled 0 127";
we'd still have to argue about the default, but the stakes would be

More information about the Pd-list mailing list