[PD] glitches when moving between sub patches

Derek Holzer derek at umatic.nl
Thu Oct 30 17:35:36 CET 2008

Hi Conor,

a few things:

1) I would check every single setting in Qjackctl against the ones you 
use in the command line, maybe there's some difference.
2) I would doublecheck how Qjackctl is called (i.e. do you start from 
commandline or menu bar, and if menu bar then how is it actually being 
3) Once jackd has been started you can start Qjackctl and use it to 
manage connections. It will recognize that the jack engine is already 
4) Yes, you could sudo qjackctl. You could also make one bash script 
that starts everything, and sudo that.


forwind wrote:
> Hi Derek,
>> Did you try running as sudo or root?
> Of course! Just tried this and yes no clicks!!!
> Before I was using qjack ctrl to control jackd. What is strange is that
> when I run jackd from command line without sudo privileges there are no
> clicks either !? 
> So following from that discovery it seems sudo privileges are not
> necessary to avoid the clicks but avoid the use of or running of
> qjackctrl under normal privileges to run the jack daemon. I wonder why
> this is ?
> odd - maintaining jack connections between apps will be a headache
> without the GUI. I suppose I could also start the qjackctrl from command
> line with sudo privileges ...
> thanks Derek,
> Conor
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list

derek holzer ::: http://www.umatic.nl ::: http://blog.myspace.com/macumbista
---Oblique Strategy # 48:
"Discover your formulas and abandon them"

More information about the Pd-list mailing list