[PD] Pd suddenly crashing

David F. Place d at vidplace.com
Mon Apr 6 01:22:09 CEST 2009


I have been using Pd quite happily under linux.  Suddenly it will not
start at all.  This is the error message I get:

> [david at Congo pd]$ pd
> pd: interval_inline.h:52: snd_interval_single: Assertion `!snd_interval_empty(i)' failed.
> Pd: signal 6
> [david at Congo pd]$ pd_gui: pd process exited

Here are the versions:

> [david at Congo pd]$ pd -version
> Pd version 0.42-4
> compiled 08:34:59 Feb 10 2009
> [david at Congo pd]$ uname -a
> Linux Congo #1 SMP Mon Mar 23 23:22:15 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Has anyone seen anything like this?  I have tried rebooting and
recompiling Pd.  I get the same message.  As you can see, I am running
the latest kernel.  Fearing that it might be the fault of the kernel, I
rebooted the previous kernel, but got the same result.  I am sure it
used to work with that kernel.

> [david at Congo ~]$ uname -a
> Linux Congo #1 SMP Tue Feb 24 19:44:45 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

Thanks in advance for your consideration.


More information about the Pd-list mailing list