[PD] pd lua error

Nicolas Montgermont nicolas_montgermont at yahoo.fr
Fri Feb 5 14:59:16 CET 2010

Hello all,

I'm trying to make pd-lua work here.

I compiled pd-lua without problem with makefile.static.
When I launch the lua-help.pd directly in the src/ subdirectory, that 
didn't worked.
this directory contains both the patch, the lua.pd_darwin and the pd.lua
I tried to compile and run with Pd-0.40.3-extended, 
Pd-0.41.4-extended-rc2 and Pd-0.42.5-extended20091214 without results,
here is the pd log for Pd-0.42.5-extended20091214 :

lua 0.5 (GPL) 2008 Claude Heiland-Allen <claudiusmaximus at goto10.org>
lua: compiled for pd-0.42 on Feb  5 2010 14:14:46
error: lua: error loading `pd.lua': canvas_open() failed
error: lua: loader will not be registered!
... couldn't create
 luax hello
... couldn't create
... couldn't create

Did I miss something?
I used pdlua on this computer two years ago, so maybe there are some 
stuffs i need to update.
I have lua-5.1.3 that seems to work (make test outputs: "Hello world, 
from Lua 5.1!")
Thanks for your help,


Ce message a été analysé contre les 'malwares' par Websense. www.websense.com

More information about the Pd-list mailing list