[PD] pd lua error

Claude Heiland-Allen claudiusmaximus at goto10.org
Fri Feb 5 16:28:24 CET 2010


Nicolas Montgermont wrote:


> I compiled pd-lua without problem with makefile.static.
> When I launch the lua-help.pd directly in the src/ subdirectory, that 
> didn't worked.
> this directory contains both the patch, the lua.pd_darwin and the pd.lua

The problem arises because:

1. lua-help.pd creates a [lua]
2. pd loads lua.pd_darwin and calls lua_setup() in it
3. lua_setup() doesn't know that it's being called by lua-help.pd
    so it doesn't know to look next to lua-help.pd to find pd.lua
4. failure to find pd.lua means that no lua stuff will work


> lua 0.5 (GPL) 2008 Claude Heiland-Allen <claudiusmaximus at goto10.org>
> lua: compiled for pd-0.42 on Feb  5 2010 14:14:46
> error: lua: error loading `pd.lua': canvas_open() failed
> error: lua: loader will not be registered!


This is most easily solved by adding the directory that contains pd.lua 
to Pd's -path.  For example, if you have:


Then do something equivalent to:

     pd -path /path/to/lua -lib lua

Future versions of pdlua might fix this common issue (or at least 
document this workaround in the error message).



More information about the Pd-list mailing list