[PD] pduino rewrite

Ingo ingo at miamiwave.com
Fri Sep 9 10:03:53 CEST 2011

Hi Roman,

I just messed around with the rewrite and - as you mentioned - you didn't
fix any of the bugs.

I even think I send you a mail about the digital pins 2 & 3 and provided a
fix for it here at the forum. Of course it's still there!

About the other things:

- The test patch has still no switches to turn on the pull up resistors.

- in Natty the comport number for USB0 is 32 that's not available in the
choices 0 - 7. I think for Linux [devicename /dev/ttyUSB$1( would be a
better choice. At least this option of naming should be mentioned somewhere
in the test patch or help patch. (maybe I missed it somewhere?)

- help-patch: there is no such thing as "PullDown". It's only "PullUp".
It should be mentioned that pin 13 does not work for "Pull Up" due to the
built in LED and resistor. There should also be a short explanation about
PullUp resistors for beginners.

- help-patch: DIGITAL-INPUT should mention the PullUp resistors. I spent a
lot of time at the beginning making lots of complicated cable connections
because the help patch recommends connecting the pins to ground instead of
simply switching on the PullUp resistors. At least as long as you are not at
the very limit of your power supply.

Since I only use the digital and analogue ins I didn't look any further. So
I can't say anything about the output stuff.

The digital pins 2 & 3 should really be fixed sometime soon. I was hoping
you'd be getting some of these problems solved rather than putting a grey
background to the help patch (lol).


> Hi Ingo
> On Fri, 2011-09-09 at 05:47 +0200, Ingo wrote:
> > OK, I got it!
> >
> > Downloading the files didn't work (at least not on my Windows computer)
> but
> > copying the content into a bunch of text files and renaming them did.
> Hm.. is this probably due to Windows and Linux using different line
> breaks (\r\n vs. \n)?
> > I'll take a look at it later to see if the problems with the 1st and 2nd
> > digital input as well as my problems with inputs 10 - 13 are gone.
> FYI: We haven't tinkered with the protocol. At this stage it's really
> only a version with some externals kicked out.
> Anyway, please report back, if you still experience the same problems.
> Are you testing on a Arduino Mega?
> Roman

More information about the Pd-list mailing list