[PD] "get" method for Pd
jancsika at yahoo.com
Mon Nov 21 21:35:55 CET 2011
----- Original Message -----
> From: Mathieu Bouchard <matju at artengine.ca>
> To: IOhannes m zmoelnig <zmoelnig at iem.at>
> Cc: pd-list at iem.at
> Sent: Monday, November 21, 2011 3:02 PM
> Subject: Re: [PD] "get" method for Pd
> Le 2011-11-21 à 12:58:00, IOhannes m zmoelnig a écrit :
>> while i'm all for "one objectclass per functionality", and
>> establishing a single idiom (at least, per "objectclass family")
> - and
>> thus think i'm with hans also, i still don't see any point in
>> "masquerading as a single class".
>> what makes the name [list foo] any better than [listfoo]?
> It's a form of namespacing.
Hyphens work, too, but two words against each other are less readable.
> Ask Hans what makes the name ::pdtk_canvas::pdtk_canvas_popup any better than
> just pdtk_canvas_popup... I don't get it either, and on top of that, I
> don't get the point of the the repetitive repetition of of pdtk_canvas
>> objects with "proper" names - that don't involve
> "mummmers" - can still
>> share the same help-patch (if needed).
> (What are you talking about ?)
> | Mathieu BOUCHARD ----- téléphone : +1.514.383.3801 ----- Montréal, QC
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management ->
More information about the Pd-list