[PD] Gridflow 9.14 w/ 64bit pd-extended 0.43.1 autobuild

Mathieu Bouchard matju at artengine.ca
Wed Feb 8 18:50:11 CET 2012

Le 2012-02-08 à 09:38:00, m.e.grimm a écrit :

> A couple questions. When I compile with opencv I get: Symbol not found: 
> _cvAdd in the pd-console. So I compiled without opencv. Suggestions to 
> fix? I have opencv installed via fink.

I have no idea. Is there still a cvAdd function in there ? It might just 
be a small Makefile issue, but I don't know. Works for me, and worked when 
I tried it on OSX with FINK.

> Also in the pd-console I get: GridFlow: can't detect this version of 
> GEM: i=10 j=4 Which I have never seen before so I dont know that that 
> means or how to fix.

It means that the GEM support has to be rewritten again, because GridFlow 
only supports GEM 92, GEM 93 alpha of the 1st kind, and GEM 93 alpha of 
the 2nd kind, but not GEM 93 final, which has again a different ABI.

I'd remove the latter two and only add support for the GEM 93 final API, 
but I don't know when I'll do that.

> Also when i "./configure" i get:
> [quicktimeapple] Apple's QuickTime:
> -------------------------------------------> missing (gcc compilation
> error)
> Is this a big problem? whats happens if i do:
> --no-quicktimeapple

It depends what you want to do with GridFlow, which can be compiled with 
whatever. It's always been possible to compile GridFlow without any video 
in, video out, live or recorded, but usually, people want at least [#out 
window] to work, and then some other things, such as camera support.

the quicktimeapple module contains support for camera and reading mov.

the quartz module contains support for [#out window].

I hear that quicktimeapple can't work in 64-bit mode because the old 
quicktime api is 32-bit only. GEM's [pix_film] has the same problem.

| Mathieu BOUCHARD ----- téléphone : +1.514.383.3801 ----- Montréal, QC

More information about the Pd-list mailing list