[PD] Freezes with Pd-Extended and Jack

Ivica Ico Bukvic ico at vt.edu
Fri Nov 23 23:03:30 CET 2012

You should check out their SVN or GIT, and compile from the tarball. There
is newer version than that available directly from the project page.


From: pd-list-bounces at iem.at [mailto:pd-list-bounces at iem.at] On Behalf Of
Esteban Viveros
Sent: Friday, November 23, 2012 12:15 PM
To: pd-list at iem.at
Subject: Re: [PD] Freezes with Pd-Extended and Jack




I tried to run Pd-Extended after and until run jack and I have the same


I forgot to say, I'm using Ubuntu 12.04 64bits ..




About Jack, I have installed the most recent version... Jack2 1.9.8 .. I'm
using the k <https://launchpad.net/~kxstudio-team/+archive/ppa> xstudio ppa
<https://launchpad.net/~kxstudio-team/+archive/ppa>  and the dream studio
ppa <https://launchpad.net/~dreamstudio/+archive/dreamstudio-stable> . I
think in there we have the most recent and stable jackd versions...


I can try contact with jack list yet..  Some suggestions?



2012/11/23 Ivica Bukvic <ico at vt.edu>

Starting jack after pd is fixed in pd-l2ork. Likewise, hanging after
connection with jack is lost is fixed in pd-l2ork. Pd 0.43 also has a
regression in its audio stack rewrite where reconnecting to jack fails and
outputs a salvo of errors (at least this was the case with the one that
ships with Ubuntu).

In respect to pd-l2ork and jack there is only one more lingering problem
which is actually related to jackd that ships with Ubuntu 12.04. Namely,
sometimes when jack is running and one somehow loses the soundcard (e.g.
accidental disconnection of a usb soundcard) while jackd is running. Killing
jackd process fixes this (since it is the one hanging and it never sends
signal to pd-l2ork or any other client that the sound is gone so pd-L2ork
waits on jackd). I was assured that this has been fixed if one compiles
latest version of jackd from source but haven't tried yet if that indeed
fixes it.


On Nov 23, 2012 5:01 AM, "Lorenzo Sutton" <lorenzofsutton at gmail.com> wrote:

On 21/11/12 23:35, Esteban Viveros wrote:


I'm using pd-extended 0.43.4, installed via Hans-Cristoph Steiner ppa. I'm
using this version because I can't install the stable version in Ubuntu

The problem is, when I start pd with Jack in -rt mode or wherever mode, if I
turn on dsp, they work well, but if I turn off, and try to turn on yet dsp,
pd-extended freeze...

Does this happen even if jack (through Qjackctl or whatever) was started
*before you start Pd??

If so I guess it could be this bug:

5736&atid=478070> &aid=3543466&group_id=55736&atid=478070

Indeed also turning DSP off when jack was auto-started by Pditselfscrews
everything up.

The workaround in this case would be to always start jack *before* starting
Pd, then everything seems to behave well.


Closing Qjackctl (after some time ubuntu can close that) pd-extended returns
to work, and I can use on alsa directly sucessfull..

Someone knows where I can comunicate this bug to the developers? Is here the

Pd-list at iem.at mailing list
UNSUBSCRIBE and account-management ->

Pd-list at iem.at mailing list
UNSUBSCRIBE and account-management ->



Esteban Viveros

(27) 8815 7170
(27) 3066 0359
(11) 95761 4125
(11) 2738 7868 

 <http://soundcloud.com/estebanviveros> www.bandpage.com/estebanviveros



 <http://expurgacao.art.br/> http://expurgacao.art.br/


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20121123/5607a327/attachment.htm>

More information about the Pd-list mailing list