[PD] audio drops for few ms, or one sec, with jack on ubuntu (was: Mess with Pd installation on Linux)

Alexandros Drymonitis adrcki at gmail.com
Thu Jan 9 10:59:33 CET 2014

On Thu, Jan 9, 2014 at 2:30 AM, Py Fave <pyfave at gmail.com> wrote:

> sorrry saw ubuntu late
> 2014/1/9 Py Fave <pyfave at gmail.com>
>> i think it's from jack setup
>> search for jack issues with your specific hardware.
>> i mean what mac do you use ,
>> jack version is important too
> Well, I've been posting on the jack mailing list too, and some people
there mention that Pd is known to have a poor Jack support...
I also get clicks with Audacity, but someone mentioned that Audacity too is
known to have a poor Jack support. Someone suggested that I use Pd with
ALSA and use an alsa-jack-bridge to send the audio to my firewire sound
card. I'll give that a shot and see what happens.
BTW, I have Jack 1.9.8

>> http://www.jackosx.com/news.html
>> 2014/1/7 Alexandros Drymonitis <adrcki at gmail.com>
>>> Just an addition to this, it shouldn't be pd's problem as I tried jack
>>> with audacity and got drop outs there as well. I'd be grateful to any
>>> help..
>>> On Thu, Jan 2, 2014 at 2:05 PM, Alexandros Drymonitis <adrcki at gmail.com>wrote:
>>>> Forgot to mention that whenever I move a window around, open a
>>>> subpatch, swich between applications while the audio is running, the sound
>>>> stops till I stop which ever action.
>>>> Also I'm running $ jackd -d firewire -d hw:NVidia (forgot to write hw:
>>>> in the first email)
>>>> On Thu, Jan 2, 2014 at 1:29 PM, Alexandros Drymonitis <adrcki at gmail.com
>>>> > wrote:
>>>>> Coming back to a previous thread I started, having compiled pd with
>>>>> jack, having done the realtime scheduling in jack, opening pd with '-jack'
>>>>> and '-rt' I still get some audio drop outs. The sound actually stops for a
>>>>> few ms, or even about a second, then comes back.
>>>>> From the previous thread I was told that probably jack is waiting for
>>>>> samples that pd doesn't provide at certain moments. I went through jack's
>>>>> manual, but it is a manual for programmers and I'm not one, so I didn't
>>>>> make much of it.
>>>>> The only thing I found in jack's FAQ is a question about audio with
>>>>> jack on a macbook (I'm on a macbook with ubuntu) that mentions a drivers
>>>>> problem that distorts the output
>>>>> http://jackaudio.org/macbook_distortion
>>>>> but my output is not distorted...
>>>>> I also tried to start up jack like this $ jackd -d firewire -d NVidia
>>>>> but it really didn't make any difference (why should it? it uses the
>>>>> same sound card with or without  '-d NVidia'). Also used QjackCtl to change
>>>>> the block size, but also didn't work.
>>>>> Dunno if this message in jack's terminal says something about the
>>>>> situation:
>>>>> JackEngine::XRun: client = pure_data_0 was not run: state = 2
>>>>> JackAudioDriver::ProcessGraphAsyncMaster: Process error
>>>>> It appears whenever I open pd with '-jack'
>>>>> I'm on a macbook 5,2 with ubuntu 12.04 and pd-0.45-4
>>>>> Can anyone help?
>>> _______________________________________________
>>> Pd-list at iem.at mailing list
>>> UNSUBSCRIBE and account-management ->
>>> http://lists.puredata.info/listinfo/pd-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20140109/f3e71a69/attachment.htm>

More information about the Pd-list mailing list