[PD] can't create [helmholtz~] on Odroid

Alexandros Drymonitis adrcki at gmail.com
Thu Jan 1 19:47:06 CET 2015

I've downloaded and copied all the files that come with the [helmholtz~]
external by Katja Vetter into an Odroid-U3 but Pd can't create it.
I've set the directory in Pd's search path, I've also tried to use
[declare], but still no luck. With [declare] I get the following message:
/usr/lib/pd/extra/helmholtz~/helmholtz~.pd_linux: cannot open shared object
file: No such file or directory

Typing 'file helmholtz~.pd_linux' in a terminal, I get this:
helmholtz~.pd_linux: ELF 32-bit LSB shared object, Intel 80386, version 1
(SYSV), dynamically linked,
BuildID[sha1]=bbe467ff0725ff41dcab644f1d5e90eb57d45c68, not stripped

while other objects, arraysize for example, give this:
arraysize.pd_linux: ELF 32-bit LSB shared object, ARM, EABI5 version 1
(SYSV), dynamically linked,
BuildID[sha1]=b2b4f077c5008c1037d0e2bd74bb8d0602e62731, stripped

helmholtz~ is compiled for Intel processors, while arraysize is for ARM, if
I get this right, so the problem is there. Checking helmholtz~ Makefile I
see that it uses the g++ compiler, which I have installed, but when I tried
to compile the source code, I got an error and the object wasn't compiled.
A funny thing is that I have the very same files in a Udoo and there the
object works fine (doesn't the Udoo work with an ARM processor?). Is there
an ARM version of helmholtz~ somewhere?

I'm on Pd-0.46-0, installed with apt-get on Debian Jessy for Odroid.

Thanks and happy new year everyone.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20150101/fe9f2c56/attachment.html>

More information about the Pd-list mailing list