[PD] Trouble Re-Installing Gem

IOhannes m zmölnig zmoelnig at iem.at
Thu Oct 12 17:27:13 CEST 2017

On 10/12/2017 05:10 PM, Greg Zifcak wrote:
> Thanks for the input all. I saw the mailing list archive but my search skills must be lacking.
> To clarify, I originally downloaded the Gem folder and placed it in the folder next to the Pd application file, and assumed correctly that this would not do anything. That is when I found out about the help menu installation feature, and installed it from there.

ok. makes sense.

> My installation process in attempting to fix the problem was: delete existing Pd folders, download Pd 0.48 or 0.47 32 bit from https://puredata.info/downloads/pure-data, then install Gem from the help menu.


> I finally solved the issue by adding the path to the Gem folder (Contents/Resources/extra) to "Startup" in "Preferences". 

actually no, you shouldn't do that at all with Gem.
Gem will (well: should) automatically add the paths, once its gets loaded.
and Gem should load fine, since the name of the binary ("Gem.pd_darwin")
matches the directory it lives in ".../Gem/", and the directory the
Gem-directory lives in (Contents/Resources/extra) is searched
automatically by Pd.
what you MUST do is to *load* Gem, e.g. by putting a [declare -lib Gem]
into your patch, or adding "Gem" (without any further path) to the
"libraries" to be loaded at startup)

> What led me down this course of investigation was that I noticed that the path Pd said it was installing Gem was
> Contents/Resources/Scripts/extra, even though it wasn't really putting it there. 

this confuses me. what's the "Scripts" path doing in here?
could you post a screenshot of where Pd says that it's installing there?

> I don't know why it didn't add a path to startup; 

Pd shouldn't (i think that feature with deken in Pd-0.48 is really a bug).
Gem would, but it needs to be loaded first.

> I'm guess it did on the first install when it originally worked. 
> I also still don't understand how the installation knew to warn me that a previous folder didn't exist,
> since I deleted the folder structure and couldn't find any other Pd folders on my system. 

i'm not sure i can follow.
how did it warn you?
if you deleted all folders and Pd warned you about a missing folder,
this sounds an ok (and totally non-magic) thing to do.

> After some of the failed installation attempts before I added the path, gemwin and gemhead appeared to be created correctly, but pix_draw and pix_texture did not (dotted lines). I assume that Gem wasn't being loaded at all since I hadn't added the path yet, and that the graphics were just inconsistent.

well, [gemhead] and [gemwin] created fine because you *did* have the
path added (they are abstractions inside the Gem/ directory).
but [pix_texture] is an object that is built-into the Gem binary, so you
need to *load* the Gem *library* first.

> Anyway, glad it's working again and I've learned a little more about how installation is supposed to work.

i think much of the confusion i'm having is because you switched between
0.47 and 0.48 during the installation and deken (the Pd package
installer) changed a bit between the two versions.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20171012/393ba53f/attachment-0001.sig>

More information about the Pd-list mailing list