[PD] [PD-announce] else 1.0 beta 5 released
Alexandre Torres Porres
porres at gmail.com
Sat Nov 4 15:10:23 CET 2017
2017-11-04 11:25 GMT-02:00 Alexandre Torres Porres <porres at gmail.com>:
> So I had a [togedge~] and [trigger~] object but was designing a third one
> named [past~], which ended up encompassing functionalities found in both of
> these other two objects, and I also hated the names of the former two
the thing about names, [trigger~] was actually a threshold detector, but I
couldn't use [threshold~] cause Pd uses it. I could also go for an
abbreviation, such [thresh~], but cyclone has one object named like that.
Since I don't want name conflicts with cyclone (cause I maintain it too).
Not only that, but as far as name precautions goes, I'm not taking any name
that belongs to any external from good old Pd Extended, that makes it hard.
So, [togedge~] was also a name that related to [togedge] from Max, but it
was a bad name and a bad relationship (cause max also has [edge~]). So
yeah, I couldn't use [edge~] either... Anyway the only solution I found
after struggling a lot was to have an object with a name that I also hate
called past~, that sends an impulse when you go past over a threshold and
another when it falls below it.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Pd-list