[PD] GOP drawing bug with scalars and z-order - test patch

Roman Haefeli reduzent at gmail.com
Sun Sep 22 21:48:07 CEST 2019

On Sat, 2019-09-21 at 12:06 +0200, João Pais wrote:
> Following the discussion, here is a patch which should be able to 
> document the issue. You'll need pd 0.5 

Oops, where can I get that? Must be from the nineties even... ;-)

> and jmmmp 0.56 to try it out.

Ok, I have now a better understanding of what your exact problem is. It
strikes me that I never ran into this. I tested it by putting some of
my own data structure stuff into GOP subpatches and putting those into
other subpatches. It doesn't happen with the patches I tried.

Are you sure it's a z-ordering problem at all? I'm not saying that it
isn't, but your patch illustrates that the arrays are not visible after
opening the subpatch and that sending 'background <clr>' helps, which
*could* be a z-ordering problem, but also something totally unrelated. 

Have you tried to boil down an example patch that is much simpler, but
still exhibits the problem? 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: This is a digitally signed message part
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20190922/24919c97/attachment.sig>

More information about the Pd-list mailing list