[PD] (PdParty) not detecting .pdz files under latest iOS

enrike altern2 at gmail.com
Mon Dec 16 16:06:52 CET 2019

>> We experienced some problems with PdParty not recognising the .pdz files
>> under latest iOS. We installed PdParty, sent the .pdz via whatsapp or
>> downloaded it from a link. Then we tried to open it but PdParty was not
>> in the list of applications available to open the .pdz.
> In that case, you can *always* connect the phone directly to computer 
> with iTunes installed and copy the files via iTunes File Transfer. 
> Otherwise, the built-in web server will work over WiFi. The steps are 
> listed in the User Guide.

ok, I will have a look. Up to now we hardly had any problem thats why I 
never read the user guide in depth.

> I think this is fixed but just not in a release on the iOS app store yet 
> via https://github.com/danomatika/PdParty/pull/70. If not, I haven't had 
> time to do a formal PdParty release yet but I've been meaning to get to 
> it this winter.
>> This happened with two phones, both running the latest iOS. Another guy
>> with an older iphone did not experience this issue. In one case
>> reinstalling PdDroid several times solved the issue but I am not 100%
>> sure,
> ... PdParty (iOS) or DroidParty (Android)? I assume the former.

sorry to be unclear. It was an iphone, the owner reinstalled PdParty 
several times and also got sent the pdz via different ways (whatsapp, 
download, email). I am not sure which one worked because I had to many 
things to deal with at the same time :( "every one running around like 
headless chickens" kind of situation...

>> the situation was a bit chaotic as this happened just one hour
>> before a concert with seven musicians involved in the middle of a bigger
>> festival and everyone was stressed and in a hurry so I could not test it
>> properly.
> Which iPhones running which iOS versions? I bet the difference is iOS 
> 12+ bringing the Files app which may have broken the document type 
> declarations used by PdParty.

I dont know, one just said she had recently upgraded the iOS and that 
sounded to me like it could connected to the problems. If you are 
interested I can contact them to ask specifically the models.

> *hint hint* I am behind the curve with testing new iOS versions and 
> devices as I'm happily running my robot cowboy rig with PdParty on an 
> iPhone 5S. If anyone would like more up-to-date support and works for an 
> institution which supports the creation of art/music and associated 
> tools, especially supporting a production which utilizes PdParty, 
> throwing a newer device at a single developer who puts out the app for 
> free would be helpful.
>> We already used the same patch months ago and there was no problem. The
>> same patch was totally fine under android, we actually solved the
>> problem by replacing the faulty iphone with an android phone.
> Ouch.
>> Sorry not to be more precise, I dont have iphones around to test it
>> properly. If someone could test it would be good to know if this is a
>> global iOS problem or something we did wrong.
> It is most likely nothing you did wrong.

ok. good to know. I was afraid it might be something wrong with the zip 
but could not see what could I have done wrong

thanks for the reply.


More information about the Pd-list mailing list