[PD] font family DejaVu Sans Mono not found on piCore

Antoine Rousseau antoine at metalu.net
Tue Feb 1 16:36:01 CET 2022

Nevermind, the tcl/tk packages proposed by the distribution were simply not
compiled with truetype support.
I took an older version of tcl/tk from raspbian and I rebuilt the tk.tcz
and tcl.tcz files (tiny core packages)  from that, and now it works, I can
edit readable patches from ssh!

Le mar. 7 sept. 2021 à 16:52, Antoine Rousseau <antoine at metalu.net> a
écrit :

> Hi,
> I'm connecting through "ssh -X" to a piCore (i.e TinyCoreLinux for
> RaspberryPi) headless install on a rPi3 (my desktop is an Ubuntu Linux).
> When I run Pd with GUI, it can only use the (barely readable, see the
> attached screenshot) default Courier font:
> WARNING: font family 'DejaVu Sans Mono' not found, using default (Courier
> 10 Pitch)
> However, the piCore "dejavu-fonts-ttf.tcz" extension is loaded, and
> fontconfig apparently does find the DejaVu font, e.g:
> ~$ fc-list | grep DejaVuSansMono
> /usr/local/share/fonts/dejavu/DejaVuSansMono-Oblique.ttf: DejaVu Sans
> Mono:style=Oblique
> /usr/local/share/fonts/dejavu/DejaVuSansMono-BoldOblique.ttf: DejaVu Sans
> Mono:style=Bold Oblique
> /usr/local/share/fonts/dejavu/DejaVuSansMono-Bold.ttf: DejaVu Sans
> Mono:style=Bold
> /usr/local/share/fonts/dejavu/DejaVuSansMono.ttf: DejaVu Sans
> Mono:style=Book
> (I have the same kind of results on my Linux desktop).
> Is there something I can do to have TclTk load DejaVu?
> Note that using '-font-face "DejaVu Sans Mono"' doesn't seem to help.
> thanks.
>     Antoine
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20220201/bb635a2e/attachment.htm>

More information about the Pd-list mailing list