[PD] [pd~] subprocess: unknown audio API specified

Phil Stone pksmusic at gmail.com
Sat Jan 28 23:13:36 CET 2023

Hi Fede and IOhannes,

Thanks so much for the quick responses. If I understand you correctly, Fede, I should *not* have DSP switched on at creation in the subprocess, but first set its audio API to portaudio, then switch DSP on? I tried that, and still get no sound output.

Also, when (in the subprocess) I select ‘portaudio’ for the API, the Audio Settings dialog pops open with my audio interface showing as the input and output devices – shouldn’t these be ‘virtual’ devices that only connect in-from and out-to the parent process?

IOhannes: I’ve made sure to have dsp switched on in both the parent and sub-process. Could you tell me what your audio API and Audio Settings show for the sub-process?

This is Pd 0.53.1, I should note.


From: Pd-list <pd-list-bounces at lists.iem.at> on behalf of Fede Cámara Halac <camarafede at gmail.com>
Date: Saturday, January 28, 2023 at 1:41 PM
To: pd-list at lists.iem.at <pd-list at lists.iem.at>
Subject: Re: [PD] [pd~] subprocess: unknown audio API specified
Hi Phil,

I've had that issue before. You might need to re-select your audio device from the Media menu before turning DSP on.
I believe that in macos it would be Media > portaudio, unless you are using jack.

I am not sure why this error happens, but I guess it relates to the pd~ subprocess changing the saved settings.

Hope this helps,


On Sat, Jan 28, 2023 at 10:30 PM Phil Stone <pksmusic at gmail.com<mailto:pksmusic at gmail.com>> wrote:
I see this same behavior with the pd~-help patch (‘unknown audio API specified’ message, and no audio output), so that rules out my synthesizer’s contribution.

Could somebody please verify that they can get audio output from the subprocess in the pd~-help.pd patch?

I’m on a M1 Mac, if that’s relevant.


From: Phil Stone <pksmusic at gmail.com<mailto:pksmusic at gmail.com>>
Date: Saturday, January 28, 2023 at 10:06 AM
To: pd-list at lists.iem.at<mailto:pd-list at lists.iem.at> <pd-list at lists.iem.at<mailto:pd-list at lists.iem.at>>
Subject: [pd~] subprocess: unknown audio API specified
Hello all,

(Further adventures with [pd~]): I have my ‘polywavesynth’ synthesizer working with [pd~]; well, except that…no sound comes out!

- The message ‘unknown audio API specified’ is displayed in the subprocess pd window.
- I have the two audio outputs of the subprocess wired to a 2 channel [dac~], and there are no audio inputs to the subprocess.
- The parent process is using PortAudio, and the subprocess appears to (correctly?) have no audio API selected.
- The subprocess Audio Settings show that the input device is unchecked and is called ‘input device 1’;
- The corresponding output device is checked and says ‘(same as input device)’.

Am I doing something wrong?


Phil Stone
Davis, California  USA
Pd-list at lists.iem.at<mailto:Pd-list at lists.iem.at> mailing list
UNSUBSCRIBE and account-management -> https://lists.puredata.info/listinfo/pd-list

Dr. Fede Camara Halac
Composer / Programmer / Sound Artist
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20230128/7e827c0f/attachment.htm>

More information about the Pd-list mailing list