[PD] GEM. pix_record producing 1 frame videos

altern altern2 at gmail.com
Tue Feb 20 17:50:20 CET 2024

Hi all

For some reason pix_record only produces 1 frame videos when recording from
the webcam. The mov files produces are however 8M big. VLC cannot open the
recorded video and only displays a small black frame with some solitary
random green pixels. PD is able to open a single frame but no more frames
can be accesed. PD says when loading the video

[pix_film]: loaded file: C:/Users/bgphumee/Desktop/photocall/test02.mov
with 1 frames (160x120) at -1.000000 fps

This happens on windows 10 Enterprise with the latest PD with GEM installed
via Deken. We also tried in another windows machine with similar results.

I made a small test from the PD help to make sure it was not my patch doing
something wrong. I attach it.

I also tried it in Linux and I get some weird results with PD freezing
while recording and not producing any file at all.

is this some bug in GEM or am I making something wrong? I have not used GEM
for three of four years and it might have changed. I searched online but
could not find any references to similar errors.

many thanks

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20240220/0ee2dc51/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test_record.pd
Type: text/x-puredata
Size: 2325 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20240220/0ee2dc51/attachment.bin>

More information about the Pd-list mailing list