Multiple definitions - templates & lists

Guenter Geiger geiger at
Mon Nov 22 19:25:56 CET 1999

0000-Admin(0000) writes:
 > well, just to take up this blurb again...
 > wouldnt it make a lot of sense to have a mechanism for naming certain
 > objects, i.e. "send", "receive", "state",... either with a $1 as argument
 > or an inlet. i am thinking of "real" instantiation of sub-patches...
 > or is something like that around anyway and i just overlooked it...
 > thats just what came to my mind while doing subpatches, lately...
 > best,
 > gert

Mhmm, I have created two objects "sendlocal" and "receivelocal" in 
ggext, which only are valid within the subpatch.

First I thought it´s nicer to do it that way, adding the same feature
to state isn't a problem, and, actually it's necessary, because the
state is valid in the suppatch only, anyhow.

Then there are arrays ... we could have arraylocal too, .....

a better solution might really be the "$0" feature, jmax has it AFAIK.



More information about the Pd-list mailing list