purepd WAS: Re: [PD] comport and bascom avr / ascii2any

Hans-Christoph Steiner hans at eds.org
Sat Nov 19 20:08:50 CET 2005

On Nov 18, 2005, at 6:14 PM, Frank Barknecht wrote:

> Hallo,
> Hans-Christoph Steiner hat gesagt: // Hans-Christoph Steiner wrote:
>> On Nov 17, 2005, at 1:47 PM, Marc Lavallée wrote:
>>> Good good, but then, how to combine those single characters into  
>>> useful
>>> messages and lists for PD? That's not an easy task, and that's why I
>>> programmed the ascii2any and any2ascii externals. I hope to update
>>> them to
>>> the latest Flext, and maybe compile it for Windows...
>> You could change [makefilename]s together, or something with the new
>> [list] object would probably be possible.
> At first I thought: No way, you'd need at least [list2symbol] for
> that, which is impossible to build with just internal objects. Then I
> said to myself: Hm, maybe it's not impossible? Then I said down and it
> wasn't even that hard to do a [list2symbol] clone using just builtins:
> list-2s.pd is attached. Oops, there goes another external previously
> used in RRADical ... ;)

That's great!  I've started a project I call "PurePd".  Whenever I get  
inspired, I write a Pd patch that is a clone of a useful external.  I  
just added it to abstractions/purepd and the build system.  It would be  
great if you could contribute this patch as [list2symbol] and anything  
else that you can think of.  I have a Max-style [counter], [speedlim],  
and even a [metro] in the works.

I have also started writing objects in Pd that make writing objects in  
Pd much easier.  Things like [float_argument] and [symbol_argument]  
which handle receiving arguments, and can distinguish between when the  
object is instantiated with an argument, and when it is not.  Other  
ideas I have for patches in this genre are a debug objects that can be  
controlled locally or by a global send/receive.  Also, I have been  
sketching out print_error and print_version objects.

I need a new name for this second project now, since it makes sense to  
keep it distinct from PurePd.  "libtools" comes to mind....




More information about the Pd-list mailing list