[PD] text3d and general pd compiling problems on OSX tiger

Luigi Rensinghoff luigi.rensinghoff at freenet.de
Tue Mar 27 18:42:57 CEST 2007

Am 27.03.2007 um 17:53 schrieb marius schebella:

> Hi,
> has someone managed to get text3d working on osx tiger?
> Now I am using pd-extended-0.39-2 and Gem has been compiled without  
> font
> support. so I tried to compile my own pd-extended, but did not  
> succeed.
> /usr/bin/libtool: internal link edit command failed
> make[2]: *** [../bin/libPdTcl.dylib] Error 1
> make[1]: *** [pd_install] Error 2
> make: *** [darwin_app_core] Error 2
> so I tried to compile everything from scratch and started with pd0.40,
> when I want to open it, I get a tcltk error...
> SetFrontProcess failed,-606
> needless to say that this is all frustrating. I would suggest to spend
> some money of the summer of code grant on making the existing versions
> more user friendly.
> otoh, what do I have to do to get text3d running?
> marius.
> _______________________________________________
> PD-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> http://lists.puredata.info/ 
> listinfo/pd-list

I have to tune into that song ;-) I guess you are an intel-user ???

I think the problem is, that extended-maintainer Hans-Christian  
doesnt have an Intel-Mac.
And the second thing: The Build system needs a user-faq ;-) Of course  
for developers its easy to modify a makefile and get this compiled,  
but..not for PD-Users.

So, if you want to compile something by yourself, its really  
complicated. It actually was easier in the old "configure-make-make- 
install" times.

By the way, did you check the "MacosxFink"- Page ???

for the detail-questions  i am sorry to say that i dont know ;-)

Bye Luigi

More information about the Pd-list mailing list