[PD] No ALSA or OSS sound with Debian 9.1 (32 and 64bit) on an "Up Board"

Ingo ingo at miamiwave.com
Fri Oct 6 23:39:52 CEST 2017

Hi everybody,

I'm trying to run my rather complex Pd patch on an Up Board (x5-Z8350
The board has the RPi formfactor but is much more powerful.

The up board comes with ubilinux (64bit debian version especially for the Up
After spending a lot of time with ubilinux and the normal debian9.1 (64bit)
I couldn't stop it from constantly crashing when I opened my patch - for
some unknown reason.
As long as I was using ubilinux sound (alsa) was working at least. Not so
with debian, though.

After giving up with the 64bit OS I installed debian 9.1 (32bit) and it's
running perfectly stable as before with my old amd hardware. No more
All externals (except for "iemlib/mp3play~" and "toxy/tot" [not to be found
anymore]) are working as expected.
However, with the normal debian alsa is NOT giving me any sound!

Then I compiled the kernel with oss but oss is not producing any sound

I installed alsa-utils, alsa-base and alsa-tools-gui.
I removed pulseaudio and I made sure alsa-utils would get started on startup
(which it doesn't by default).

Here is what I get from pd when turn on alsa:

ALSA input error (snd_pcm_open): No such file or directory
ALSA output error (snd_pcm_open): No such file or directory

The (external USB-)sound card does show up in the drop down menu of Pd's
audio settings for selection, though.
So it is regognized both by pd and the operating system. I tried several
different USB sound cards with the same result.

Here is what I get when I try to open alsamixer from the LXTerminal:

error when opening mixer: No such file or directory
(original in German: Fehler beim Öffnen des Mixer-Gerätes: Datei oder
Verzeichnis nicht gefunden)

When I use portaudio I'm actually getting sound but it is very quiet as the
sound output is turned down by the system during start up.
I can't find any way to turn the volume of the sound card up, though since I
cannot open any mixer.

Does anybody have an idea how I can get alsa to work?
Debian tells me that "alsa-utils" and "alsa-base" is already installed with
the newest version (1.1.3-1 and 1.0.27+1).

Thanks, Ingo

More information about the Pd-list mailing list