[PD] Issue with PD .50.0 + Windows Driver?

Rick Snow ricksnow at gmail.com
Mon Jan 6 20:18:25 CET 2020

Thank you both for the advice.  There was no other option for input device other than the ASIO: Realtek ASIO.  

However, I just installed the ASIO4ALL v2 driver and set both input and output to use it and now the headphone jack gives the correct test tone.

Still not sure why the original driver would have stopped working but glad things are working now.  

Thanks again,

> On Jan 6, 2020, at 12:42 PM, Andrew Lyons <tstexture at gmail.com> wrote:
> I would hazard a guess that the Asio/mmio input/output combination is the problem. Does the ASIO:Realtek ASIO output option work? Have you run the "Sound settings" troubleshoot tool? 
> I found the distorted output to be related to block size and delay values in pd prefs/audio settings. Making those values larger cleaned things up.
> On Mon, Jan 6, 2020, 10:27 AM Rick Snow <ricksnow at gmail.com <mailto:ricksnow at gmail.com>> wrote:
> Hello list,
> I wonder if someone here can give me some advice..  I am in a situation where I need to run PD in coordination with Processing on a high end windows machine running Windows 10.  Everything worked perfectly until this morning.  Now PD’s audio is not working at all.  Audio from a web browser works fine.  Audio from Audacity works fine although I don’t see any options for an input audio device (not that I have one plugged in).
> When I open PD and run test audio midi I get this error message:
> “error opening audio: Illegal combination of I/O devices”
> When I open Audio settings, I have:
> input: ASIO: Realtek ASIO
> output: MMIO:Speakers (Realtek(R) Audio)
> There are no other input device options.
> For output I have these options:
> MMIO:Microsoft Sound Mapper - Output
> MMIO:Speakers (Realtek(R) Audio)
> MMIO:PHL 276E8V (2-NVIDIA High Defi
> MMIO: Digital Audio (S/PDIF) (Realtek
> ASIO:Realtek ASIO
> If I turn off the input device (uncheck) I am able to get a very distorted test tone.
> This problem seems to have started soon after I tried changing my screen resolution and then changing the pd font size and stretch options. I don’t know if this had anything to do with the problem or not though.
> I have tried reinstalling PD a couple times and reinstalling the Realtek drivers.
> Thanks for any advice.
> Cheers,
> Rick
> _______________________________________________
> Pd-list at lists.iem.at <mailto:Pd-list at lists.iem.at> mailing list
> UNSUBSCRIBE and account-management -> https://lists.puredata.info/listinfo/pd-list <https://lists.puredata.info/listinfo/pd-list>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20200106/88b270fa/attachment-0001.html>

More information about the Pd-list mailing list